[Linux-Snap]: Can't reopen after installing from snap

Steps to reproduce

I installed Obsidian from snap. When running for the first time it loads correctly. However, when closing and re-opening, nothing happens. Even if I try to run from the command line with obsidian nothing happens and there is no error printed out.

Expected result

Would expect Obsidian to run

Actual result


  • Operating system: Ubuntu 18.04
  • Obsidian version: 0.8.9

Additional information

$ obsidian && ps aux | grep obsidian

I can confirm this but actually haven’t really cared about it since the Appimage works fine.
The inside updates don’t seem to be working either with the Snaps.

I ended up switching to Appimage as well

Does this still happen with the latest installer 0.8.12?

Still the same.

Still the same with 0.8.15 and I can’t test it with 0.9 because I can’t download it directly.

I have the same problem with 0.9.20.

1 Like

Still the same with 0.9.20 version.
Also unable to open a folder as vault in snap install. When I try to choose an existing folder, the home shows nothing.

Is this a snap permission problem? Where did you put that vault?

My vault is under ~/Documents/Projects/Notes/Obsidian/, so outside ~/snap/obsidian/.

Same problem here. But I know it is AppArmor that is blocking the obsidian snap. On first run, it is ok, but then it blocks. The dmesg command shows issues accessing


but I don’t know how to fix them:

[42104.606318] audit: type=1400 audit(1614628405.833:533): apparmor=“DENIED” operation=“open” profile=“snap.obsidian.obsidian” name="/run/mount/utab" pid=353761 comm=“obsidian” requested_mask=“r” denied_mask=“r” fsuid=2508 ouid=0
[42661.813027] audit: type=1400 audit(1614628963.031:534): apparmor=“DENIED” operation=“open” profile=“snap.obsidian.obsidian” name="/snap/core/10823/usr/share/locale/fr/LC_MESSAGES/snappy.mo" pid=358243 comm=“snap-exec” requested_mask=“r” denied_mask=“r” fsuid=2508 ouid=0

Some Googling suggests this might be a snap bug, not Obsidian’s: Dmesg error message - snapd - snapcraft.io

I agree, Snaps can be problematic at times—they are blocked by default in Linux Mint 20 for a reason …

I’ve been using the AppImage ever since, and it works just great.