[Linux-Snap]: Audio recorder not working - Ubuntu 20.04

Steps to reproduce

  • Click Audio “Start/Stop recording”

Expected result

  • Audio recording should start

Actual result

  • nothing happens


  • Operating system: Ubuntu 20.04 LTS
  • Obsidian version: 0.8.12 (uninstalled old version and reinstalled from scratch using snap)
1 Like

Working as expected on Ubuntu Mate 20.04 LTS with AppImage

Just tried it with AppImage - there it works for me as well. Thanks!

So the bug seems to be in the snap installation?

I tested it with snap and with Flatpak, in both it doesn’t work either. The following message appears: “no microphone is connected”, but I use a notebook.

Version: 0.9.4

I’m afraid I can’t reproduce it either (Ubuntu 18.04 + AppImage).

cc @htuy for the flatpak version

Whoops. Yeah this is on us, we forgot to enable PulseAudio access in the flatpak, this will be fixed soon. In the mean time, please install Flatseal and grant this permission manually. I’ve tested it and it works after enabling this permission and restarting obsidian. @marcelobritox3

1 Like

Update: flatpak has been fixed to enable PulseAudio access by default :slightly_smiling_face:

1 Like

Thank you very much, it worked for me.

@1dan please open a new bug report with the template. A lot has changed since this was archived