[Linux] Freeze when spellchecking a word with rightclick

Bug
When your Spellcheck language is German, and you spellcheck a word with right click, that is wrong, but can be fixed, Obsidian freezes for a pretty long time. I tried English, and the freeze is basically non existent. I also tried Spanish spellcheck, and it also freezes but, for way less time. What I also found out, Is that when the word is complete gibberish, obsidian sometimes freezes and sometimes doesn’t.

Steps to reproduce

  • boot up Ubuntu
  • open obsidian
  • create a new vault
  • create a new file
  • enable spellcheck, language = German
  • type a wrong word, but not complete gibberish (Example: Apelbaum instead of Apfelbaum)
  • right click the word that is underlined red
  • your obsidian will freeze for a pretty long time
  • then the right click menu will show up

Expected result

  • The right click menu comes up instantly, like it does when spellchecking a word in English, or a word that isn’t underlined red

Actual result

  • the rightclick menu comes up after a pretty long wait

Environment

  • Operating system: (GNU/Linux) Ubuntu 22.04.1 LTS
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.1.9
    Installer version: v1.1.9
    Operating system: #64-Ubuntu SMP Thu Jan 5 11:43:13 UTC 2023 5.15.0-58-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 5
    Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information

I also tried the glitch on windows, but it didn’t exist there.
Here is a video of me performing the glitch:
https://b.catgirlsare.sexy/WlZbSlXk02Cf.mkv

(post deleted by author)