Linux can't open vault on another partition

Context

I dual-boot Windows and Linux. I am trying to share my vault between the two operating systems.

Problem

Both the appimage and the snap package can’t open vaults in other partitions even when they are mounted.
When I select a folder in one of my shared partitions, it says “Failed to open. no permission to access folder.” (Yes, the typo is there).

It normally would not even let me open the other partition in the selector. I was able to get this working with sudo snap connect obsidian:removable-media. This allows you to browse within other folders, but it gives the error message if you select a folder in them.

I classified this as a bug because it is a disruption of the usual functionality I get on Windows, and because it is making me unable to access my notes on a supported platform. You can move it if you want, but please, fix this problem.


Update: It just suddenly started working. I have no clue what happened to make it work but it is now. I am still on the same version of Obsidian and distro.

Aside from the typo, are you sure that obsidian has access?

What do you mean? My problem is that it does not have access. I tried to grant it access in all the ways I knew how. I tried the command that I listed above (which apparently works for some other snap apps according to here) and that allowed it to browse those folders in the vault selector, but did not stop the error message. I tried symlinking (even though that didn’t even seem like it would work) which failed. If you have any solutions I would be happy to try them. I am not super amazing at fixing these kinds of problems yet.

However, I do think something should be done to fix this. It works in Windows, and I think that, if possible, something should be done to make sure this works out of the box.

Getting something to work in all possible varieties of Linux setup isn’t necessarily simple. Even for apps aimed only at Linux. I’ve always had to fiddle around with it a lot, especially sharing data in a dual boot. Mainstream has probably been tested and tweaked by the OS developers, but other things are iffier.

If you have your vaults saved or synced with the cloud, one option is to keep the local vaults separate each being kept up-to-date by the cloud syncing.

Yeah, intercompatibility in Linux can be a real pain. I have so far tried it on a couple distros and neither worked (one debian based and the other ubuntu based). I am guessing this problem just requires some permission changes. I completely understand if it can’t be done, but I do at least want to let them know about it. I will keep trying to fix it on my own and if I find a solution I will let people know.

As a workaround in Linux try creating a symlink from one folder to another. As far as I know in Windows 10 symlinks are also possible.

I tried that, and it was not working. It had the same error. It is working now that the problem in general is not happening. I don’t know what changed between then and now though.