Links to external files with escaped spaces no longer supported?

Steps to reproduce

I am using external links to files outside the vault like this: [file 1](<file:///C:/somepath/file%201.txt)

Expected result

This used to open the external file when clicked on or using Alt+Enter / Ctrl+Click in edit mode.

Actual result

Brings up an error message “file could not be found”.


  • Operating system: Win10
  • Debug info:
    Obsidian version: v0.13.21
    Installer version: v0.12.5
    Operating system: Windows 10 Pro 10.0.19042
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


Additional information

Same error occurs when trying such a link in the help vault.
Links without escaped spaces still work: [file1](<file:///C:/somepath/file1.txt)

1 Like

[file 1](<file:///C:/somepath/file%201.txt) this format is non sense.

what do you get from drag-ctrl-drop the file to your note?

I am sorry, the ‘<’ should not be there. And it is not what is causing the problem. I had been trying the alternative with <…>, which also worked.

When I drag-ctrl-drop I get this:
[file 1.txt](file:///C:%5CUsers%5Cmz%5CDesktop%5Cfile%201.txt)
which opens in Preview mode with a click but in Live Preview causes the “file not found” error.

will be fixed in 0.13.22

1 Like


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.