Linking to block does not show target text

Once you’ve done the above, delete everything above this line.

Steps to reproduce

I work on multiple systems, 97% macOS, but various macOS versions. I wanted to get to know linking to the bottom, i.e. not only be able to link to other md notes, but also to headings and blocks.
Therefore I started to follow examples from the page, but I could not get linking to block to work.
To debug and find the culprit / reason, I tried doing the same on multiple macs. These macs run various versions of macOS: Mojave (2 systems), Catalina (1 system), Monterey (2 systems)

Did you follow the troubleshooting guide? [Y]

Yes I did.

Expected result

When typing [[name of noteˆ]] I am expecting to see a pop-up with a list of the block(s) in the target note. When doing the same with purpose of viewing the target note’s h1, h2 etc headers everything works as expected.

Actual result

No pop-up with list of target note block(s)


Obsidian version: v1.3.7
Installer version: v1.3.7
Operating system: Darwin Kernel Version 19.6.0: Tue Jun 21 21:18:39 PDT 2022; root:xnu-6153.141.66~1/RELEASE_X86_64 19.6.0
Login status: logged in
Catalyst license: insider
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 6
Restricted mode: off
Plugins installed: 28
Plugins enabled: 0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

Up to today, this issue was limited to my Mac running Catalina. To run an additional check, I fired up my 2013 Macpro (Trashcan) that is running Mojave too, and on that machine, running Obsidian 1.3.7 (installer 1.3.5) the same thing happens.

The unfortunate thing is that I can not:

  • reproduce this on all my mac machines
  • can not seem to find the culprit of this issue in order to keep working in a reliable way with obsidian
  • can not link this issue to Catalina solely because it is appearing on Monterey too
  • I have done the test with the sandbox vault on two machines where the issue appears, a 2018 Mac mini running Catalina and a 2013 Macpro running Monterey

=> Please help or point to help on how to solve this issue?
[email protected]

wild guess. Is it possible that the character that you use for linking to blocks is not the right one?

Correct ^
Wrong: ˆ

1 Like

Hmm, the one I use is shift + 6.
I do notice another on the onscreen keyboard, but that’s the ctrl-key.

Also, I’m testing this on multiple computers each with their own keybloard / touchpad.


Your wild guess is correct!
I checked the keyboard settings between macs, and have:

  • US
  • US International - PC

The US Intenational - PC is misbehaving…
Problem solved!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.