Link to a single word in a note

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

I try to link a single word in another note. I am able to link to a other note, this is easy, but I can’t link to single word in a text. An example: note with some text and a word beginning with “A” that a want to link to this → other notes like a lexicon, note “A”, “B”… in “A” there are some words beginning with an “A” and the explaination text for that

Things I have tried

I tryed to insert a link with strg + k, I tryed to type it manual with “[”, “]]”… I can only link the note “A” but not a special text block

thanks for help :slight_smile:

You cannot link to a single word, but to blocks (= a paragraph); see this explanation.

ok, thanks, I dry to use it… with the explanation I can link to a tagged block, but if I klick on link, only on the left side of my note I get the possibility to klick on a short form of that note and then I jump to the block I’d linked before. I can not jump automaticly after a klick on the link to the linked block… what’s wrong?

Linking to blocks is different from tagging! Can you share how your link and your target paragraph look like?

the blue text in the note “Einleitung” should be the link:
and the target ist note “B” block “Beobachter” in the last row of the picture:

If you know the location of the target block [[noteName^searchWord|newName]], or [[^^searchWord|newName]] if you do not know the exact file.

in your case it might be something like
[[^^Beobachter, immer → tab for auto-completion → enter |Beobachter ->volia!


you write in the first line: target block [[noteName^searchWord… in the second line [[^^…
if I need a single ^ i must type twotimes ^^ and then backspace do delete one ^… I tryed both variations but the target do not reached correctly… the jump adress is in my case #Banken instead of #Beobachter… (you can see/located that in the second picture)
the way to the jump to “#Banken” is:
[[B#^38067b|Beobachter]] the “38067b” is build by obsidian, i wrote “Beobachter” behind the “^”

This is probably because you you don’t have an empty line between your paragraphs. In markdown, paragraphs are separated by empty lines. In obsidian, you can adapt the way your paragraphs appear by activating or deactivating “Editor → Anzeige → Strikte Zeilenbegrenzung”; this, however, doesn’t break basic markdown rules.

By the way: A “” is written in markdown by typing → instead of ->. You should really learn markdown if you want to work with a markdown editor (which obsidian basically is).

ok, thank you! the only one I found in german is a 1-pager with a syntax overview :smile:
i will learn markdown,
I will try your advice, and will answer

:slight_smile: it works! between the paragraphs one empty line

and thanks too for the advice to write an arrow →

You can also paste the arrow character into the text. The method suggested above is part of HTML (Markdown allows HTML to be used). There are also a variety of ways to type special characters (a web search will help you’re curious — the ways depend on what operating system you use).

do you have an idea, why it works on the first link perfectly “^38067b” shows not in the “reading mode” and the second one “^77633a” it is visible in the reading mode?

Could you paste the text here in a code block so we can see it more exactly?

Also it’s best to start new threads for new questions — anyone who isn’t already participating in the thread will see it marked as solved and probably not read the new comments.


the following is from a footnote:

[^4]: Vgl. im Lexikon: → [[B#^77633a|Beobachtung]]

is this the problem, thats in a footnote?

Could you paste the same text you showed in the screenshot, so we can see the ^77633a in its context? I suspect it needs a blank line under it or to be moved to the end of the preceding line.

:slight_smile: thank you! that’s it… blank line under it and all is good :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.