Link Text Overlap/ display error in Live Preview

What I’m trying to do

I am trying to write a list of obsidian links.

What is the Problem?

In Live Preview the text of the links has a display error as can be seen in the attached picture.

tags: test
# aesdfasdfa

## afeasdfasd
[[one wonderful note]]
[[two wonderful note]]
[[three wonderfulzl note]]
[[four wonderful note]]
[[another wonderful note]]
[[and yet another]]
[[and another another another]]

## Tools
[[Neural Networks]]
[[Convolutional Neural Network]]
[[Feedforward Neural Network]]
[[Recurrent Neural Network]]
[[Bayesian Learning]]

Things I have tried

I encountered the problem in my working vault with lots of plugins. I created a new test vault and was able to reproduce the error without changing any settings. (Happens in Light and Dark Mode, but is more prevalent in Light Mode)

Hovering over the links results in the error disappearing for the duration of the hovering.
Having the cursor at different positions changes the display temporarily.

Cursor behind [[Convolutional Neural Network]] or [[Feedforward Neural Network]] leads to the display error constitantly.

System Information

v1.3.7 (AppImage, Installer Version v1.1.16)
Linux Ubuntu 22.04.3 LTS

1 Like

I can’t reproduce

please, download and reinstall obsidian. post a screen recording of this happening in the sandbox vault.

Tried the following:
“wrong” words appear to make the problem worse.
Deactivating spellcheck seems to “fix” the issue.
So the problem might be pinpointed there.

Deleted the AppImage, downloaded the AppImage, integrated it, opened the sandbox vault
ZIP file contains the .webm Screencast of this happening in the sandbox vault, as requested.

Screencast from 10.08.2023 (617.2 KB)
The pasted text:

- [ ] [[Bohl2023SPI]]
- [ ] [[Bonilla2023SPI]]
- [ ] [[Bradde2023SPI]]
- [ ] [[Choi2023SPI]]
- [ ] [[Garbuglia2023SPI]]
- [ ] [[Huddar2023SPI]]
- [ ] [[Huynen2023SPI]]
- [ ] [[Javaid2023SPI]]
- [ ] [[Lahbacha2023SPI]]
- [ ] [[Leslie2023SPI]]
- [ ] [[Lin2023SPI]]
- [ ] [[Manfredi2023SPI]]
- [ ] [[Manoharan2023SPI]]
- [ ] [[Paulis2023SPI]]
- [ ] [[Phung2023SPI]]
- [ ] [[Plot2023SPI]]
- [ ] [[Selezinski2023SPI]]
- [ ] [[Telescu2023SPI]]
- [ ] [[Uebach2023SPI]]
- [ ] [[Vashishtha2023SPI]]
- [ ] [[Verma2023SPI]]
- [ ] [[Zhou2023SPI]]

this seems a GPU rendering glitch, try running obsidian with hardware acceleration off (settings>advanced).

Might depend on X11, wayland, xwayland, whatnot.

Yes turning of hardware acceleration helps, but won’t that “degrade performance severely”?
Also as I mentioned before, turning of Spellchecking also does the job.

Both fixes seem to be workarounds.