Link block to the same line as the link

Things I have tried

Created a link block, but it doesn’t allow me to link to the same line. I’ve tried manually creating a reference on that line (something like ^73jfse), but that didn’t seem to work either.

What I’m trying to do

I would like to create a link to the same line/block which the link is on. My use case is I have a note with all of my open tasks. These tasks are from many different notes. I would like to create a link in that task, back to the exact line where that task exists. My workaround for now is to link to the line under the task (in the original note) where I usually keep notes regarding the task.

Is there a way to do this or is just a limitation of the linking mechanism?


The format for this is ![[Name of the file#^block text]]. When you type ![[ you will see a list of files at which point you can start typing text until you see the file you are looking for. If you press TAB you then type #^ and you will see all the blocks in that file. You can start typing the text of the block you are looking for. Hit TAB again and you will be done. This video shows the format in action.

Unless you’re in a specific task list, the smallest target you can get is a block. And as you’ve discovered the block in the context of tasks is the entire list (in my experience).

I’m not quite sure how Dataview links to the exact task within that particular list block, but I reckon it’s using some search mechanism, because I tried changing the text of the task, and then the link is off. (Unless you change it using the visual attribute of the task)

Thanks for the quick replies! Unfortunately, it does appear to be by design. I haven’t played around with Dataview yet, but that might be something to look at soon.


In the picture you are showing, you are missing the ! symbol at the beginning of the link you are creating. This should be ![[Test Note^#...]]

I think we may be on different pages here. I am trying to link to that specific line, not embed the referenced content. Here is the same issue, if I were attempting to embed content.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.