Lines not correct when exporting to PDF

What I’m trying to do

I recently switched to Obsidian on Mac because trying to print my notes from OneNote was a big pain in the ass. A problem that has occurred with this app is that when I export the file to PDF, it doesn’t really match what it looks like before I export.

The main issue is when I hit enter before a sentence is finished. It squeezes those lines together when exporting

Things I have tried

I’ve tried a lot of plugins and I’ve also searched the web. I’m new to both coding and Obsidian so I’m just saying sorry in advance if this sounds stupid.
Would love to keep on learning and developing my skills in this field.

I’m adding a couple images, the second one is what the PDF looks like and how the lines get pushed together instead of staying separate.

You could try putting two spaces after the final word in the paragraphs to create a line break. e.g.


... årsak.<space><space><enter>

... utføre.<space><space><enter> 

and switch to Reading view. You’ll have a close approximation of what the exported PDF will look like.


https://www.markdownguide.org/basic-syntax/#line-breaks

To create a line break or new line (<br> ), end a line with two or more spaces, and then type return.


edit: I neglected to mention, but you’re most likely to see the behavior in your export screenshot with Settings > Editor > Strict line breaks enabled. You could use the double spaces or if you disable that setting, you should be able to do without them at the end of paragraphs.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.