Line length in Edit View vs. Preview (inifinite vs. fine)

Things I have tried

What I’m trying to do

The screenshot above shows a new note, two views synced.

Edit view on the left. Preview on the right.

Content: 1 word, 130 characters.

Obviously, the editor doesn’t wrap this word, while the previewer does. The dividing, vertical line can be moved. Both views adapt. The editor reveals more or less of the line (word). While the previewer always shows the entire content, according to its frame, currently available (as you would expect).

I worked through everything (?), e.g. this entire thread:

Adjustable “Readable Line Length”

At least, I managed to limit the edit window size to whatever I like, e.g. by using the following CSS sippet:

.markdown-source-view,
.markdown-preview-view {
  max-width: 590px;
  margin: 0 auto;
}

But: none of these CSS attempts even come close to my actual problem: these never endling lines in the edit view.

No matter, what I’ve been trying to adjust the “Readable Line Length” etc.

So, I end up with an editor, that’s neither readable nor writable. And I’m wondering, there are thousands of Obsidians out there. Am I the only stupid one? :slight_smile:

Any hints welcome!

Ok. Here’s the answer:

Settings > Editor > Line wrap ON

1 Like