Line Breaks in Obsidian Markdown are Inconsistent with Conventional Markdown

What I’m trying to do

I am trying to understand a quirk of Obsidian Markdown formatting. Specifically, in most Markdown syntax, a double space creates a line break. In Obsidian, a double space does not appear to do anything. I’m not sure if there is a setting I am not seeing, or if this is an intentional aspect of Obsidian’s Markdown syntax.

Things I have tried

Here’s a document in Obsidian

Here’s the same document rendered with traditional Markdown

I may post this in feature requests or meta depending on the responses. But as a first pass, I am curious about if this behavior can be modified by a setting, or if it is an intentional feature. In my opinion, Obsidian syntax should be as compatible with conventional Markdown as possible, with the only differences being feature additions (e.g. Wiki-links), rather than core features of the syntax. Especially because as far as I can tell, double spaces in Obsidian don’t serve any other purpose, so they might as well be link breaks just to preserve some cross compatibility.

Try enabling Settings > Editor > Strict line breaks and report back.

It looks to me like your problem is unrelated to line breaks and you need to put a blank line between that paragraph and the table.

If that isn’t it, where are you putting the double spaces? They only indicate a line break when placed at the end of a line. (And by default Obsidian breaks this rule, treating newlines as line breaks; this can be changed by the setting that ariehen mentions.)

1 Like

Yeah, I wasn’t sure what was happening with the table example, but was going off this to start: