LaTeX vertical bars are not rendered

What I’m trying to do

I am trying to write matrixes in latex that have vertical bars, such as this:

However, what I end up with is this:

Things I have tried

I have tried doing this three ways:

  1. The vmatrix environment
$\begin{vmatrix}a & b & c \\ d & e & f \\ g & h & j\end{vmatrix} = a\begin{vmatrix}e & f \\ h & j\end{vmatrix} - b \begin{vmatrix}d & f  \\ g & j\end{vmatrix} + c \begin{vmatrix}d & e \\ g & h\end{vmatrix}$
  1. The \mdet command in the physics package
$\mdet{a & b & c \\ d & e & f \\ g & h & j} = a \mdet{e & f \\ h & j} - b \mdet{d & f  \\ g & j} + c \mdet{d & e \\ g & h}$
  1. The array environment
$\left| \begin{array}a & b & c \\ d & e & f \\ g & h & j\end{array}\right| = \left| a\begin{array}e & f \\ h & j\end{array} \right| - b \left|\begin{array}d & f  \\ g & j\end{array}\right| + c \left|\begin{array}d & e \\ g & h\end{array}\right|$

All three approaches produce the same outcome with no vertical bars. However, the following actions do result in proper rendering:

  1. Disabling hardware acceleration
  2. Setting font size to 10. Does not work for any size larger or smaller
  3. On my android devices, it renders fine.
  4. Any matrix with only one row has proper rendering

However I can’t really work with font size 10 or disable hardware acceleration, so if anyone could help fix this issue that would be great.

Hi, so I was having this same issue with the vertical bars in vmatrix not rendering.
This code:

resulting in something like this:

Instead of something that looks like this:

Ultimately, what fixed my problem was going into the editor, toggling the “use legacy editor” button so that I could relaunch, then relaunching the program. After I relaunched Obsidian, vmatrix was working as it should again. Hope this helps.

I guess the above link might be related to your problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.