LaTeX equation not appearing correctly

Things I have tried

I’ve taken the spaces out (saw another post suggest this!) and copied and pasted the code block into overleaf and this comes up correct when document compiled

What I’m trying to do

I’d like to have this equation appear correctly in my obsidian note!

it should appear like this
Screenshot 2023-01-26 at 11.39.46
but is somehow appearing like this

and I cannot fathom why! I have checked the code (copy + paste) into overleaf and it is just fine in there… any help/guidance here appreciated! Thanks :smiley:

Aren’t you supposed to use double dollar signs for it to render as a block?

Something like the following:


Disclaimer: I’ve not looked at the equation code, at all, just the surrounding syntax

yep, tried that and that doesn’t change anything :') I only changed to single dollar signs so I could fit the entire thing in the screencap

Are you trying to make it appear inline? Isn’t it then a default behavior that fractions are shown like that?

No, I normally use single dollars and the fractions have been fine before… very bizarre indeed

Mighty strange, I’m not able to produce that single line version. With the following:

test: $A_U\equiv\frac{\Gamma(\sin{2\Phi}>0)-\Gamma(\sin{2\Phi}<0)}{\Gamma(\sin{2\Phi}>0)+\Gamma(\sin{2\Phi}<0)}$

I still get this output (on Android):

If you still get the single line version, I would check for updates of Obsidian, restart Obsidian, and possibly go into the sandbox vault to see if it appears the same there.

If OK in the sandbox vault, are there any settings or plugins you’ve recently started using or changed settings for which could affect this?

And if nothing else helps, please post the “show debug info”, to see if anyone catches anything when reading that

Thanks so much! I’ll try these things :smiley:

OK. Well. None of the other things worked so just quit and reopened and now it is fine. Classic technology… thank you so much for the help :))

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.