Large tables render slowly or misrender

Steps to reproduce

  1. Download a raw copy of large table example gist
  2. Store the downloaded file in your vault
  3. Attempt to open table in Obsidian for rendering

Did you follow the troubleshooting guide? [Y/N]


Expected result

I’d expect the table to render correctly and within a few seconds. GitHub’s gist service renders the file quickly and without incident.

Actual result

The table can take a long time to render (15+s). Other times it won’t render at all. And in the worst instances, it will partially render and then mangle the source.

I’m building up a document of the CRuby VM instructions. While the total number of instructions is fairly small, it appears my notes including code samples have caused the renderer to struggle. While the document is perhaps larger than many tables, I don’t think it’s in the realm of unreasonable. As noted, the linked gist loads fully rendered almost instantaneously.

If the renderer cannot be optimized to render quicker, then it would be better to fail safely. Mangling the source is not a great solution (it’s possible that was due to a plugin, but the other rendering issues are present in a sandbox vault). If it gets to a point where it can’t render at all (e.g., double-clicking the file in a sandbox vault appears to no-op), it’d be great if it could print an error. And barring all else, it should present an error if the table is too large.

I’m in a weird position now where Obsidian can’t open a file it authored. I can switch to another editor to split the file, but that’s not ideal. I think at the very least, the no-op indicates a bug somewhere.


	Obsidian version: v1.5.12
	Installer version: v1.4.16
	Operating system: Darwin Kernel Version 23.4.0: Fri Mar 15 00:10:42 PDT 2024; root:xnu-10063.101.17~1/RELEASE_ARM64_T6000 23.4.0
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

1 Like

Looking into this a bit more, the reading view renders very quickly accurately. It’s the editor view that’s problematic. While it struggles to load the document, clicking the book icon in the upper-right-hand corner at least lets me view the document quickly.