Lag when typing (Windows-only?)

Steps to reproduce

Creating a note and typing starts to lag visually after a few words.

Expected result

Words appearing on-screen at the rate in which I am typing them.

Actual result

Writing starts to slow down after a few words and continues to lag.


  • Operating system:
  • Debug info:

Obsidian version: v0.16.3
Installer version: v0.15.9
Operating system: Windows 10 Enterprise 10.0.19044
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 9
Plugins enabled: 7
1: Periodic Notes v0.0.17
2: Dataview v0.5.46
3: Note Refactor v1.7.1
4: Tag Wrangler v0.5.3
5: Calendar v1.5.10
6: Natural Language Dates v0.6.1
7: File Info Panel v1.2.5

Additional information

I’ve tried disabling plugins, disabling all plugins (restricted mode), I’ve written in a browser, Word, and Visual Studio Code, and compared my laptop keyboard with my external keyboard. I also write in Obsidian ~ 50/50 Windows and Mac every day with some iOS thrown in and it’s only on Obsidian for Windows that I’ve noticed this. It’s actually been like this for a month or so because I notice it the most when I’m in meetings and transcribing the conversation (and then I promptly forget about the issue until another meeting happens).

does it happen in the sandbox vault?

Giving more system info will probably help; What’s the ram and processor in your computer?

Good point! I thought it was with the rest that I copied and forgot to check.

IBM ThinkPad
Processor Intel(R) Core™ i5-6300U CPU @ 2.40GHz 2.50 GHz
Installed RAM 20.0 GB (19.9 GB usable)
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Is there a THE Sandbox, or do you mean creating a new vault and testing there?

I just created a new vault and it happens there too. If there’s a sandbox vault please let me know and I’ll try there too.

bottom left corner ? → open sandbox vault.

I would also check if third party programs are operating on your vault.

Oh wow, that’s good pc specs. I have windows and lower specs too and the same version of obsidian and I haven’t seen any lag thus far. So not sure

Ah. I had always assumed that icon went to the help docs directly. Thanks. I tried sandbox and it’s working as expected - no lag.

This is a very corporate laptop so I’m going to say there’s definitely some software running on this directory and all the rest that I don’t want there. That said I see that they set up OneDrive to grab the Documents folder that my vault was in. I copied my vault to another directory that I have access to and I’ll see how it goes. It appears to not lag yet. Thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.