Korean language bugs (when we type)

### Steps to reproduce

[https://www.dropbox.com/s/gckkr4t8yf6ngwt/obsidian%20bugs.zip?dl=0](https://www.dropbox.com/s/gckkr4t8yf6ngwt/obsidian%20bugs.zip?dl=0)

(hyper link of screen records of the bugs)

  1. when i type Korean language and try to modify some words with backspace button in the middle, a connected letter with the letter i just delete changes its shape. and if i delete that changed letter as well, the previous letter also changes its shape. it kind of keep going on and on until i press space bar and begin to delete letter again. (then i can finally delete a single letter in a normal way) (watch file 1)

  2. ‘ ‘ ← when i type a korean word between these apostrophes, like this ‘가이아’
    watch the screen record (file2). suddenly the last word 아 became 아아 when i typed only one 아. it seems one apostrophe(‘) changes the shape to 아.
    it happened occasionally. not every time. but quite often as much as i feel so much bothered

  3. this may not relate to specifically Korean language issue, but i just found out this issue as well. please watch file 3.
    when i pressed hotkey (that i assigned for) for ‘toggle code’ for a quite long sentence, some weird phenomenon happened. it’s hard to put into words. you’ll get when you watch

i read some Korean language bugs report from forum and it seemed the issue was resolved judging by conversation of the comments section.
but the phenomenon seemed a bit different with the one i’m reporting
in Korean appstore, there are quite a lot of people who report this kind of similar issue for Obsidian.
they really want to keep using this brilliant app, but the issue make us think we maybe shouldn’t
i’m aware Apple note app also has an issue with Korean language when we type. idk what is going wrong with our language :joy:
i hope this kind of issue will please be resolved here Obsidian so this app can thrive in my country

Environment

  • Operating system:
  • Debug info:
    i pad os 15.7.1
    i’ve got 2 ipads and the issue happens for both
    i checked this happened in Obsidian app for iphone as well (ios 16.1.1)
    i haven’t tried Obsidian for mac yet

in the screen records, you can see i was using WASP theme, but after i read your instruction, i changed the theme to default and checked if the issue continues. and it did continued regardless of what theme i use.


aside from the issue, i strongly wish for obsidian to have “understrike” feature
i don’t feel it’s sufficient to mark information only with bold, italic, highlight
according to the structure i set up for text marking function, sometimes understrike is really needed to organise and highlight some information in a bit mild way?, so to speak
it helps me understand my text much more organised way
i want to use highlight only for really strongly important information
and i’d go bold and understrike for less important
and they can be used being mixed
they’ve got a sort of hierarchy when it comes to importance
you know what i’m saying

Thank you for the report. It’s generally better to post on issue per bug report.

Do these bugs happen if you use source mode?
Do these bugs happen here https://codemirror.net/try/?c=aW1wb3J0IHtiYXNpY1NldHVwLCBFZGl0b3JWaWV3fSBmcm9tICJjb2RlbWlycm9yIgppbXBvcnQge21hcmtkb3dufSBmcm9tICJAY29kZW1pcnJvci9sYW5nLW1hcmtkb3duIgppbXBvcnQge2xhbmd1YWdlc30gZnJvbSAiQGNvZGVtaXJyb3IvbGFuZ3VhZ2UtZGF0YSIKCi8vIFRoZSBNYXJrZG93biBwYXJzZXIgd2lsbCBkeW5hbWljYWxseSBsb2FkIHBhcnNlcnMKLy8gZm9yIGNvZGUgYmxvY2tzLCB1c2luZyBAY29kZW1pcnJvci9sYW5ndWFnZS1kYXRhIHRvCi8vIGxvb2sgdXAgdGhlIGFwcHJvcHJpYXRlIGR5bmFtaWMgaW1wb3J0LgpsZXQgdmlldyA9IG5ldyBFZGl0b3JWaWV3KHsKICBkb2M6ICJ0ZXN0IGhlcmUiLAogIGV4dGVuc2lvbnM6IFsKICAgIGJhc2ljU2V0dXAsCiAgICBtYXJrZG93bih7Y29kZUxhbmd1YWdlczogbGFuZ3VhZ2VzfSkKICBdLAogIHBhcmVudDogZG9jdW1lbnQuYm9keQp9KQo=?

got it. thank you for informing!
however, i’m not aware of what is the source mode
and i couldn’t get the picture even after i read the text in the link page
did you mean that i can try to write Korean on the link page and see if the bugs still happen in the same way it did in Obsidian app?

image

yes

ok. i tried for both, and both resulted in having the same bug issue when i type Korean and in the process of modification

1 Like