Issues with sharing vault between multiple operating systems

Things I have tried

I tried looking for “text encoding” and “opening same vault in different OS” and haven’t found the answer I was looking for.
I am putting this in “help” because I think there is something I am missing and that the devs have addressed, since it seems quite obvious.

What I’m trying to do

My vault sits in an exFat partition that I use to store files that I need to access both from my Windows and my Linux installation, files edited in Windows end up looking like this when opened in Linux ( this only happens for files that were created in windows, older files that were just updated don’t have this issue ). Thank you for the help.

Make sure that the font you are using on Windows is installed on your Linux machine.
I use Obsidian on Windows 10 and Garuda and do not have any issues with text rendering.


Also, from above it looks like Windows prefers UTF-16 for text …

Obsidian only reads and writes UTF8.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.