Issues with .Obsidian folder for CSS snippets and # Headings

What I’m trying to do

I am having issues trying to use CSS snippets, but the .obsidian folder is grayed out and I can’t put anything in it. I can see the files, just can’t access them.

In addition, headings are not working anymore, not sure if I turned off a setting for them.

Things I have tried

I’ve tried looking at the forum, on reddit, stack exchange and quora but haven’t found any answers yet

The cloud-and-exclamation-mark icons shown on many of your files suggest a problem with a cloud service (probably that those files aren’t downloaded, or uploaded). What operating system is this on, and what are you using to sync?

I’ll take a stab at this. It looks like you’re on a Mac. After you click on the .obsidian folder (a hidden folder), press Shift + Command + period, and you will be able to open the folders inside, including the snippets folder. After you are finished doing what you want to do, press the same keys again to return the folder to its hidden state.