Issues with modifier keys on iOS with hardware keyboard

What I’m trying to do

I normally use a pc, so my memory of hotkeys is all based on using ctrl, alt, and shift. But, I use an iPhone, so with my newly purchased Targus Ergonomic Foldable Keyboard, I have adjusted the iOS settings for the hardware keyboard such that pressing: Command=Option, Control=Command, and Option=No action.

Within Obsidian, I am able to press the keys that I am used to pressing to perform the commands I want. However, I am unable to jump from word to word using Control+left/right. In other applications, interestingly, I am able to still use Command+left/right to jump from word to word, but not in Obsidian.

So, my current understanding is that the iOS settings for the modifier keys on the hardware keyboard strictly refer to how the modifier keys are interpreted when being used for hotkeys that are not hardcoded into the OS, such as Command+left/right.

This still leaves me a little confused as to why pressing Command+left/right does not work within Obsidian. To be clear, I am concerned about using more than just Command+left/right, but am using that as an example. As I am typing this forum post out using the keyboard on my iPhone in Safari, Command+left/right is working “correctly”. I put the word “correctly” in quotes because technically I would like for apps to respect my alteration to the modifier keys in the iOS hardware keyboard settings, but that is besides the point. And to be clear, other hotkeys within apps such as Safari, do respect the hardware keyboard modifier key settings. So, when I press Contol+c, it successfully copies the selection to the clipboard.

Any guidance would be helpful. Thanks so much!

Things I have tried

I have tried searching for information but haven’t found any answers yet.

Thanks again!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.