Issues in Using Callout with Code Blocks

Steps to reproduce

  1. Create a note, use callout with code block, type ` 3 times and an issue occurs in the auto-completion of the code block. There is no > on the left side of the 3 `.

  2. If the code block has <>, it will cause a rendering error.


  3. If use \ to escape, it may look normal in edit mode, but in preview mode the code block does not recognize the escape character \ and displays \, even though the rendering is no longer incorrect.


Did you follow the troubleshooting guide? [Y/N]

Yes, I created a new repository without any community plugins enabled and still repeated the above issue.

Environment

SYSTEM INFO:
	Obsidian version: v1.5.11
	Installer version: v1.4.13
	Operating system: Darwin Kernel Version 23.4.0: Fri Mar 15 00:12:41 PDT 2024; root:xnu-10063.101.17~1/RELEASE_ARM64_T8103 23.4.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none


Additional information

I noticed that some blocks of code can be loaded correctly in the callout, so I presume that Obsidian wants to be as compatible as possible with this situation, so I’m reporting this issue.

Seems to be this one:

Yes, I apologize for not going through the list of reports more carefully. But I noticed this is a 2022 issue, so why hasn’t it been fixed yet?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.