Issue with the graph view when using external drive

What I’m trying to do

I have my obsidian vaults saved on an external drive and have never had any issues. Since today (obsidian version 1.6.2) the graph is not working properly (nodes are moving/shaking, typing&toggling settings in the graph view is very laggy)

graph view in a new blank vault:

graph view in my own vault with theme (the “shaking” of the nodes is more extreme & same issues with lagging while typing and toggling graph settings):
https://imgur.com/a/5mB6aUf

The issue only appears in the normal graph view, local graph view works fine (no lagging while typing/toggling etc.

Things I have tried

The issues only appear when accessing vaults on my external drive (but I haven’t had any issues with it before today)

Is it not possible to use an external drive anymore? I don’t have that much storage on my computer and also like being able to use my notes on different devices so having to store my vaults locally would be very annoying for me haha…
Is there a fix for this to continue using the external drive :confused:?

I also tried reinstalling the driver for the external drive.

Same issue here.