Issue with Cursor Behavior in Editor After Update to 1.5.8

I am reaching out for assistance with a recent issue I’ve encountered in Obsidian, following the update to version 1.5.8. The problem arises specifically when editing lines that include checkboxes (formatted as "- "):

  1. Cursor Positioning: While navigating through the text using the up or down arrow keys, the cursor automatically positions itself after the checkbox rather than at the beginning of the line where it was before. This irregular behavior extends to selecting text, where the cursor moves right after the checkbox.
  2. Editing Challenges: This unexpected cursor movement complicates the process of deleting lines with checkboxes, requiring manual repositioning of the cursor in front of the checkbox every single time.
  3. Cutting and Pasting Issues: Additionally, this behavior adversely affects cutting and pasting operations. When attempting to move a checkbox line up or down, the cursor’s automatic jump to after the “]” symbol complicates the task.

Prior to this update, such behavior was not observed. I have reviewed all available settings in an effort to identify a solution or a workaround, without success.

Has anyone else experienced similar issues, or does anyone have a solution or suggestion to share? I appreciate any guidance or advice you can provide.

Thank you!

You will have to provide system information. I cannot reproduce your issue on Linux Fedora with Obsidian 1.5.8.

For easy deletion of checkbox items and bullets, consider the hotkey Ctrl+D (“Delete Paragraph”), which is by default set up. (This is easily triggered, but there is also Ctrl+Z for undo).

Thank you, I’m using Windows 11. Ctrl+D works, but I often move checkbox lines up and down and cut a line here, paste it there. It works fine on previous versions, I had to go back to 1.5.3, but the last version keeps moving the cursor to just after the “]”. When moving up and down and selecting.

Again, I cannot reproduce the issue on Linux: for me, the cursor stays before the - also when moving to different lines, and when moving from regular text into a bullet list.

If bullet points are moved only in the neigborhood, consider assigning a hotkey to the “Move line up” and “Move line down”. It allows you to move a checkbox line seamlessly with a single keystroke. You can select multiple bullets (e.g. the “children”) to move the blocks at once.

You do not have the “Outliner” community plugin installed? That plugin will cause more like the behavior you observe, however intentionally so.

Thank you for the suggestions! I’ll certainly look at the hotkeys and “Outliner” plugin. It seems that this maybe is a bug with the Window build since you can’t reproduce it on your Linux version. I also submitted a bug report, but haven’t had any replies. Hopefully it will be seen and corrected in future versions.

I am also experiencing an identical issue. When I am moving down a line and my cursor is already in front of the checkbox, I go naturally to the correct point on the next line down. However when my cursor is behind my checkbox, I end up in front.

Example (using a pipe | for the cursor)

Through text in front of checkbox :white_check_mark:

##### 8|am
- [ ] Duoli|ngo

Through text behind checkbox :x:

##|### 8am
- [ ]| Duolingo


##|### 8am
- [ |] Duolingo

I can also confirm that the cutting/pasting is a massive issue for me too. I suspect @jaw1 uses Obsidian similarly to me, with copy/pasted task lists and re-ordering all the time.

I am running on macOS Sonoma 14.1.1 with Obsidian 1.5.8 (from homebrew). I do not have the Outliner plugin. Here’s the full debug info:

	Obsidian version: v1.5.8
	Installer version: v1.4.14
	Operating system: Darwin Kernel Version 23.1.0: Mon Oct  9 21:27:24 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T6000 23.1.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: dark
	Community theme: none
	Snippets enabled: 1
	Restricted mode: off
	Plugins installed: 6
	Plugins enabled: 4
		1: Self-hosted LiveSync v0.20.2
		2: Hider v1.2.5
		3: Templater v1.16.0
		4: Fantasy Statblocks v3.15.2

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I previously missed that this question concerns checkboxes, not bullets. While it works correctly with bullets (- ), I can reproduce the issue with checkboxes - [ ] . This indeed causes friction when you want to cut/copy and paste entire lines in Live Preview mode (it continues to work well in Source mode).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.