Is there supposed to be a cache file

Obsidian doesn’t start and gets stuck on the “loading cache”

With some help, I discovered if I delete the community plugin json file, it will start. Then, I have to turn on all the plugins again. Tiresome.

Is there supposed to be a cache file or folder? My vault has none.

I think caches are stored elsewhere on the system.

It sounds like the problem is caused by a plugin. To verify that, turn on Settings > Community Plugins > Restricted Mode and restart Obsidian (you might need to restart twice given this problem). If that fixes the problem, then update all plugins. If updating doesn’t cure the problem, you’ll need to track down the culprit. If you have a lot of plugins, the Divide and Conquer plugin can help.

Perhaps

1 Like

Cache on Windows is kept in the %%APPDATA%% directories as discussed here: Stuck on Loading cache - #23 by wealthychef

Have you tried removing the -cache IndexedDB entries?

Have you tried removing some of the .json files from within your .obsidian/ vault? The .json files from individual plugins if you aren’t running in restricted mode?

I know it’s a pain to redo settings, but I’ve had things just not work before because of a jacked .json file.

edit: I now see you posed in the other thread after this one. :sweat_smile:

1 Like