iPhone won't sync, local not iCloud vault, iPad and Windows laptops both work fine

I find a lot about iCloud related issues but nothing on my problem yet. I had originally used iCloud as it did keep my laptop and iPad in perfect sync, but not the iPhone. So I created local vaults on all three devices. The Windows laptop has the folder that is synced with the Obsidian Sync tool. The iPad and iPhone each have local vaults synced to the same Obsidian Sync connection. The iPad works fine. A document updated on the laptop appears in seconds on the iPad. On the iPhone nothing is syncing since the day I set up the sync a few days ago. The Sync activity viewer shows files being pushed by the laptop but they never appear in the iPhone vault. What steps can I take to resolve or at least find out what’s not working? I’ve disabled and renabled the sync on the iPhone and have removed and reinstalled the iPhone app. Thanks.

What I’m trying to do

Things I have tried

From what device are you looking at the sync log?
The log is not shared between devices.

You mention that neither iCloud nor Sync synced your phone. Could it have some kind of networking problem?

Thanks. On the iPhone that will not sync the Sync Activity view shows it connects and the viewer shows that the server, my Windows machine, has pushed a file. My iPad says the same at the same time and it gets the file. The iPhone does not.

The only way I’ve found to get 45000 files (my old Evernote) that work fine in my iPhone is to install Obsidian on the iPhone, and create a new empty local vault. I then copy all the files from my working Desktop or iPad to an intermediate folder on iCloud. Then on the iPhone, I copy those files in the Files app from the iCloud intermediate folder to the empty local vault on the iPhone without Obsidian running. (My original post was because my iPhone spent 7 days non-stop syncing and never did finish.) I can then load Obsidian and sit through a four-hour indexing but that beats seven days.

The issue is that some of the files on my Desktop use Templater code and if I turn on Community plugins on the iPhone app the iPhone app will restart every time I touch the setup gear button. The only way to fix that (is there an Obsidian safe mode I don’t know about?) is to remove Obsidian and the data, repower the iPhone and start over.

It doesn’t appear that iPhones can use the Templater Communtity plugin.

Say what you will about Evernote… it did this part really well.

I’m pretty sure iPhones can use Templater. But Templater gives you a lot of power, you have a high number of notes, and iPhones have less RAM then Macs, so you could certainly be hitting a limit.

In addition to “server pushed” you should see “downloaded” and “accepted” messages for each file. Do you see those on the phone?

Is your phone’s storage full? (Tho I expect you’d see an error in the Sync log if that were the case.)

Have you tried rebooting the phone?

Yes. Each iteration I reboot the phone and it has half of its 256gb storage free. It’s 6gb RAM is much more than the 2Gb on the working iPad version that syncs fine. (both devices are latest IOS). I get a successful connection and “Detecting Changes” but no files appear in the local vault newer than the last dump of all files in the process I describe above.

Do you see the “downloaded” and “accepted” messages in the log?

Never did see any message that a file was accepted (or not for that matter) only the server pushes and the fact that the iPhone was “Detecting changes”. So here’s my hypothesis. If, as I did, you want to add another device to a large collection of notes, simply copying those notes outside of Obsidian hoping that you can turn on sync and update that collection with new changes won’t work. Though it doesn’t specifically say so, it appears that a FOLDER created after the folder was created on the original file source will never download a note in that folder, newer or not. If I start with an empty new vault and connect that to sync, all the folders do correctly come down to the new vault from the old. I’d like to know if that hypothesis is correct in anyone else’s experience. So I solved my problem by starting with an empty vault, managing the exclusions to allow only a small subset at a time to start and finish syncing.

I don’t know why you saw the behavior you did, but I’m glad you were able to work around it.

I think you should be able to turn on Sync in an existing copy, but it’s been a while since I had to do anything like that. If the copy ends up with newer last-modified dates than the original I could see there being problems — altho I’d expect the problem to be the copy overwriting the original which isn’t really a problem. If I get some spare time I’ll test on a little test vault.

Before you took the new approach, did the iPhone’s Sync log ever say “fully synced”? I should have asked that.

Thanks for the reply. I had gotten a fully synced message then, outside of Obsidian, added some folders and files as that was faster (I thought) than using sync before the problem arose. I did hear back from the Obsidian Sync support team and they confirmed that an existing folder, not just a file, will confuse sync and they only recommend syncing to a new empty vault. That worked. Took four days but it worked.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.