iOS shortcut and URI help

Things I have tried

I’ve read through Obsidian docs for using the URI but can’t seem to get a new note to save in folder/sub-folder. I can only get a new note (created through an iOS shortcut) to save in the root of the vault.

Have also checked out the forum on iOS shortcuts which is really great! As well as some online searches for basic Obsidian tutorials.

What I’m trying to do

New to Obsidian. Long time user of Bear. I am really liking this app so far. Used to have an iOS shortcut that generated a daily note in Bear. I’ve copied that over to Obsidian but have a couple of questions. My daily work note goes into /<Company_Name>/Daily Notes/<Note_Name> However, I can’t seem to get the note to go into that exact location. I’ve tried using path, file and name. Seems like I can only get the note to save when I use file and it puts it in the root (where I can then move it where I want it).

Second issue is with the iOS shortcut. When I run the shortcut manually, it works great! Generates my daily note with no issues. But when I try to run the shortcut with an automation, I get an error that it cannot find the Vault.

Can you give some more detail about the things you’ve tried that don’t work?

I have a shortcut that saves to a folder. It’s a little hard to read because of the variables, but here’s the relevant part:

The “Name” variable holds the name of the note.

This was awesome! Thank you very much! Totally helped me with getting my note into the right folder.

So, onto my next question…when I manually trigger my shortcut on my phone, it works perfect. No issues at all. However, when I create an automation to run my shortcut at a set time, I get an error saying the automation failed. Shortcuts could not open the app for the URL scheme “obsidian”. The app may not be installed on the device.

How does it work just fine when run manually but not as an automation?

I don’t know — I only use mine manually.

I’ve noticed that obsidian URLs don’t work correctly when Obsidian has been pushed out of memory (and so has to restart when opened up). In that case it only opens the app and doesn’t do the other things it’s supposed to (open a note, create a note, etc). It’s probably not the same problem, but as a test you could try making sure that Obsidian was the last thing opened when the automation runs, to see if that matters (if it does I don’t know a solution, but at least you’ll have more info).

EDIT: Now I can’t reproduce the problem I described.