iOS copy-paste text with colon results in Markdown link

Paste results in extra control characters. See screenshot. First paragraph was copied, second is the pasted result.

Only occurs on mobile iOS (17.2.2), not desktop. Occurs in restricted mode with native theme. Occurs with any copy/paste, as far as I can tell. Restart was not helpful.

Before opening a new bug report, please search the forum for duplicates and follow the Troubleshooting Guide.

Yeah, that’s odd. Something about the : in there, one will do, is causing the text to be copy/pasted as a URL/Markdown link. Breakfast none, of course, copies & pastes fine.

In a new vault, copy and pasting with iOS’s Copy and Paste pop-ups:

Breakfast:: none
Breakfast: none

result in the Markdow-ish links:

[Breakfast:: none](breakfast:%3A%20none)
[Breakfast: none](breakfast:%20none)

Using the command palette’s Paste command, both are pasted fine.

   Operating system: ios 17.3.1 (Apple iPhone16,1)
   Obsidian version: 1.5.8 (126)
   API version: v1.5.8
   Login status: logged in
   Catalyst license: supporter
   Live preview: on
   Base theme: adapt to system
   Community theme: none
   Snippets enabled: 0
   Restricted mode: off
   Plugins installed: 0
   Plugins enabled: 0


Changed the thread title to describe the problem. (Was “Copy paste broken on iOS”.)

1 Like

The double colon, “::” signifies an inline Dataview field.

I have been doing copy/paste of these fields for as long as I can recall, on a daily basis. Only recently has this odd behavior arisen.

My guess is that iOS interprets the text and classify the clipboard content as an URL in HTML, which we then in turn try to convert to markdown when you paste.

This may be an iOS bug and the way around it is to paste as plaintext

You can always paste as plaintext

will be fixed 1.5.9

I don’t see an option to paste as plain text. How is that accomplished? Thanks.

You can swipe down from the top for the command palette and type Paste and hit done, although that may not be ideal depending on where you are in the note.

You can also add the command to the mobile toolbar. (Settings > Mobile → Manage toolbar options)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.