[iOS] Can't Exit Community Themes Page on iPhone

When you go into the community themes page in iOS, there is no way to exit back to the previous menu. Need to kill and restart the app to get out of the screen.

Update: if you press in the upper left in the exact correct place it will return you out, but there is no arrow visible.

Missing navigation buttons are on the list of known issues.

Is there any space above the community themes pop-up where you could press? (I can only test on iPad, so I have more space, that’s why I’m asking.)

See the upper right where I drew a red box. This just needs to be a back arrow like on the other screens. The area in the box is active and takes you back when you select it, there is just nothing there to show where to press.

I get it now, thank you for the screenshot.
I agree that there should be a back arrow.

Is that with no custom CSS?

That image has custom CSS, but same issue with no custom CSS.

Thanks for clarifying, I just wanted to make sure that it also happens with the standard theme. :+1:

Should be fixed in 0.0.11, could you verify @jdinning ?

It isn’t fixed, there’s still no back button in the community themes.

That’s weird, the base CSS is designed to leave a 10% gap on top so you can tap the background to close this. Doesn’t look like it’s happening here - anyone else can repro?

Ah, I thought you meant to add navigation buttons.
On my iPad there is enough space above it, but that was already the case before.
Someone with an iPhone would need to confirm that there’s enough space above it now.

Sorry, I missed this. Correct, it is not fixed in 0.0.11.

Can you share a screenshot of what it looks like? I’m also assuming you aren’t using any themes or snippets when this happens, right?

@Licat there is a screenshot at the top of this thread. Your interface has changed slightly since I took it, but you can see where the red box that I drew is. Your other nav screens have a left arrow there. This is a total nit, because if you just click in the blank space above, it takes you back. However, all other screens also have the left arrow in the upper left.

I understand what you mean - I’m just asking for a screenshot of what it looks like in the latest version to check whether it’s still not showing the space up top.

As for the left arrow, some page have them when they come from navigating another page within the same modal dialog, but modal dialogs don’t all have them. In this case, the community theme page isn’t part of the settings modal but it’s actually completely on its own, so having the top space to tap to close it right now makes sense.

I understand. What you say makes sense. The first level menus have the arrows, but when you go into either community themes or community plugins, the behavior is consistently as you describe. I think it is good the way you have it. I am attaching a screenshot so you can see it, but I think you are good here.

Perfect, thank you!