[iOS] Cannot "Select all" (text)

I am on iOS using/repro’ing in the Sandbox vault, using the latest 1.4.6 version.

What I want to do:

In source mode or live preview, long press anywhere > select all > all text would get selected.

What happens instead:

Nothing, apart from the cursor being brought back to 1,1 position.

I tried Reading Mode as well, where in the main text area, “Select all” doesn’t even get offered.

This is an important thing that needs fixing.

I am sure on PC, Contr+A works, and because I have no external keyboard on the iPad, I cannot try this key combo.

1 Like

thanks

Came here to report something very similar. On iOS when pressing anywhere > select > then dragging the selection handles upward through a lot of text, as the screen is moving up the selection handles will just stop and disappear. It only happens when dragging the selection upward. Dragging downward seems to work fine on any length of text. I can also replicate the select all issue too.

Do you happen to be using the Minimal theme? If so, it’s a bug in the theme and unrelated to the OP’s issue.

https://github.com/kepano/obsidian-minimal/issues/510

No I’m using the default dark theme, but I have a few snippets I added to change the background color and some text and heading colors. No themes or plugins installed though. I tried it again today and it only seems to be happening once I reach the very top of the page when selecting upward. Previously it was doing it at any random spot. I tried turning off the snippets and it still happens.

I’m now also noticing some page stuttering/pausing as I’m scrolling up and down a long page.

Platform

[X] iOS
[ ] Android

Obsidian Mobile version: v1.1.0


Choosing “Select All” from the popup menu in Edit mode does nothing.

iPadOS 15.2.1

1 Like

Thank you! I’ve been meaning to report that. iOS/iPadOS 15.3.1.

1 Like

Okay, that’s weird. It works on some notes, but on others it just jumps the insertion point to the top of the page.

After testing a handful of pages, I think it mainly fails on longer pages.

I hadn’t noticed the insertion-point jump until you mentioned it. For me in the middle of a long page it disappears, and I might find it at the bottom, at the top, or not at all. Starting with it near the top of a page, I saw it jump to the top.

1 Like

Please prioritize this one. Without Select All, some operations become very difficult.

is this happening with iOS17?

Yes, I’m still receiving this issue with IOS 17 and the latest Obsidian version

I still see this problem on iOS 17. When checking in my test vault, “select all” worked on a very small note and failed on a larger one.

1 Like