Installing Obsidian without root access

What I’m trying to do

I am trying to install Obsidian on an extermely locked down version of CentOS. I don’t have access to installers or anything so everything has to be done via command line or the graphical file manager. I have no root access nor permission to issue a sudo command.

I’ve tried downloading the tar.gz Obsidian file, and unpackaged it. However, there’s no executable in there nor do I really know how to build the application. I don’t really know what I’m doing, I’ve tried this with firefox and it just seems to work as there’s an executable once I unpackage the tar.gz file.

Hi hmacaroni,

For CentOS, I recommend downloading the AppImage version from the Downloads page. It is an executable file all by itself, and you can execute it by going to your downloads folder and executing:

chmod +x ./Obsidian-0.12.19.AppImage
1 Like

Thanks Craig, this solution seemed to work with a small tweak. An error came up running the second command “The SUID sandbox helper binary was found, but is not configured correctly.”

Changed to

chmod +x ./Obsidian-0.12.19.AppImage
./Obsidian-0.12.19.AppImage --no-sandbox

which worked fine (except it also says “Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.” but this does not seem to influence the app itself).

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.