Inside math/latex environments the autoclose bold, italics etc should be disabled

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Inside a fresh vault enable the “Editor > auto pair markdown syntax” option, insert $$ and place the cursor between the $ signs. Type an * or a _.

Expected result

In a math environment, it’s more common for these characters to mean either

  • a subscript when using an underscore _
  • a complex conjugate (at least in physics) when using a astrisk *

I would there expect obsidian to ignore this feature when inside a math environment.

Actual result

Instead we get two of the character with the cusror placed in between them.


	Obsidian version: v1.2.8
	Installer version: v1.2.7
	Operating system: Windows 10 Home 10.0.22621
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

I can’t find any discussion of this or a community plugin that would handle this. Regardless, it feels like a bug to me as I would expect a mathjax user to want to insert markdown syntax inside mathjax.

1 Like

Moved to Feature request.

This is in the same vein as

1 Like