Insert key does not put into overwrite or overtype mode

What I’m trying to do

I’m trying to type in overwrite mode, so that newly type characters will overwrite existing characters instead of inserting and pushing existing characters to the right.
Why? Because this very handy when working in tables.

Things I have tried

I’ve tried the insert key. It does not seem to swap between insert and overwrite mode.
I’ve tried going into source mode, no change in the behavior, the insert key does nothing.
I’ve looked through the documentation, and found nothing about it.
I tried searching in the hotkeys to see if the ins key was just not bound, but “insert” only pulls up entries that have nothing to do with my issue and “Overwrite” or “Overtype” get nothing.
I searched the forum, and could find at least two times this exact question has been asked previously, without getting an answer in 90 days.

I’m using Obsidian 1.3.7 on a linux machine running Xubuntu.
My default editing mode is live preview, and I do NOT have VIM keybindings on.
Also have “Use legacy editor” off.

Does obsidian just not support overwrite/overtype mode?

Thank you.

1 Like

I’d love this too. Is it possible too re-tag this as a Feature Request? It might not be something Obsidian does already. Might get more attention with that tag.

1 Like

This isn’t structured as a feature request, so it’s better to write one fresh.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.