Input error with Devanagari / other Indic scripts

Steps to reproduce

When typing with “Indic” / Abugida scripts, such as Devanagari, conjunct characters do not display correctly. Normally, two consonant characters combine together to create a new character that fuses them. However, when typing such characters, rather than combining them correctly, a “dummy” character is created between them, so that they display incorrectly (shown in screenshot). I do not work with Southeast Asian scripts such as Thai, but it’s possible that they will produce the same error since they are usually incorporated into unicode under the same system.

Expected result

Example: the correct form would be: स्वराज

Actual result

When typing in Obsidian, however, the result is: स््वराज


  • Operating system: MacOS 10.14.6
  • Obsidian version: 0.9.6

Additional information

What input method do you use?
Does this happen in the filename? Does this happen in the search box?
Does this this happen in other electron apps? like discord or slack?

I’m using the standard MacOS Input—the error is reproduced regardless of input source (i.e., keyboard layout), and occurs anywhere in the app (file name, search). It is not reproduced if I copy in text from somewhere else.

The same error occurs in Slack, so it might be a problem with electron?

If it happens in slack too, then it’s mostly likely an electron issue and it will be handled upstream.


Quick update on this bug—it seems not to occur in Atom (I hadn’t realized that Atom also runs on Electron). This might indicate that the bug doesn’t occur in all electron apps.

If you uninstall and reinstall from the latest available version on the website, does it help?

Just tried that and no, that doesn’t seem to produce any change.

Just wanted to update—as of the most recent version (on a new MBP M1, though that shouldn’t matter), the error has resolved itself. The issue had previously resolved on an update of Slack as well, so I assume that electron fixed it.

thanks for updating the report.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.