Indexing

Things I have tried

What I’m trying to do

i’m new to obsidian and added about 20k md documents from DT3 that i have used as notes over the years. every single time i open obsidian, it reindexes my vault, which usually takes about 15 minutes. it says each time that it usually only needs to happen once, but its done it 6 or 7 times in the 3 or so days i’ve been using the program. anything i should do about this? no photos in these docs or anything, just text only MD files.

But did it finish indexing or is it just continue indexing?

it finishes. and then when i open up again, it starts up again.

Does it start from 0? Where are your files stored exactly?
Can you post a screen recording?

yes, it starts from 0. stored in a regular folder called “documents/obsidian vaults/quotes.” i can post something next time i reopen but for now i’m hoping to not reopen until later because i have work i want to do and don’t want it to have to reindex. any thoughts from this alone? should i try to move those files to a new vault?

do you use hard drive or SSD, are the file synced with some service?

no syncing. SSD.

I’ve started noticing this issue since the 0.12.3 update, although the indexing is done more quickly in my case. The most intriguing thing is the message claiming “This should only happen once”.

My vault is stored (and synced) in Dropbox. When I open my vault on a different device from the last one I’ve used, Obsidian does this indexing.

Which file is being created with this indexing process? Maybe I can investigate further from that.

1 Like

How big is your vault (how many notes) and what are your computer specs? How long does it take to finish?

I worked with Obsidian several days on my PC (Athlon 64 X2 cpu 500GB hd 8GB ram - Windows 7) - over this time I’ve created/modified 81 md files.

Today I’ve opened Obsidian on my Notebook (Ryzen 5 cpu 1TB ssd 12GB ram - Linux Mint), and the indexing process message appeared showing the progress over 81 files. It took 5 seconds to do this.

My vault has 1440 md files right now.

Just for the information of anyone who is interested,I’ve noticed my vaults seem to be indexed each time I restart too. The only difference is I only have a few dozen notes so far (not that experienced with MD yet xP), and it goes really fast. It never takes more than like 3-7 seconds.

However, there have been a few times where it seemed to become “stuck” during indexing, and just sits there. To fix this, I minimize the app and then maximize/restore it, and it seems to stop indexing and go straight to the vault. I’m not sure if anyone else has experienced this latter “issue”, but I thought I’d share, as it seems somewhat related to this post, I suppose. Good luck with your obviously frustrating issue. I wish I could help, but at present I’m too newbish to do so.

You have a small vault.
It is normal for obsidian to reindex the first time you open a vault in a new computer.

If it keeps reindexing on the same computer every time. Disable every theme, every css, put obsidian in safe mode, and restart. If it still happens, post a screen recording of that.