Indenting a list removes checkboxes

Steps to reproduce

When I enter Source mode and tab on one of the numbered checklists, all of the boxes below will be removed.


Windows 10 Profesional 64 bits



Things I have tried

  1. Reboot computer
  2. Restart Obsidian
  3. Turn off community plug-ins

What I’m trying to do

The checkboxs below should not be removed.

The syntax for checklists is ‘- [ ]’, so an unordered list. You may be able to type a checkbox in a numbered list, but I think the behavior you’re seeing is because Obsidian still sees your numbered list as a numbered list and not as a task list. Does this behavior also occur if you change to an unordered task list and then indent one of the tasks?

1 Like

Thank you for your reply. Unordered task lists work just fine.

Has indenting an ordered task list worked before? If so, what you’re seeing may be a bug in either Obsidian or a plugin you’re using. If not (I can’t get it to work in my vault but I’ve never tried before) then it’s probably Obsidian not supporting numbered task lists.

1 Like

if u manually type it, u indeed can make it work. i guess it’s just the tabbing act makes it convert to normal ordered list


anyway, if u use Outliner plugin, u can tab without the checklist overriden.
Recording 2023-01-31 at 15.58.44

No, indenting an ordered task list has never worked before.Since manually typing three spaces worked, I think it’s a bug.

Thank you so much. Manually typing or Outlinear solves the problem.

Typing 3 spaces works because Markdown requires 4 spaces for a hierarchical indent. So when you indent by 3 it’s not a sub list, it’s still part of the main list.

You clarified my ideas, thank you so much.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.