Incorrect Indentation Behavior with Quotes and Item Lists

Once you’ve done the above, delete everything above this line.

I have noticed a bug in Obsidian where the indentation behavior is incorrect when a quote (“>”) is placed under an item (“-”) in a markdown file. When I indent the line containing the quote using the tab key, the tab is inserted after the “>” symbol instead of before it. This causes the collapsing item functionality to break.

Steps to reproduce

Create a new markdown file in Obsidian.

  1. Type the following content:

    - Item
    > Text
  2. Place the cursor before the “>” symbol on the second line.

  3. Press the tab key to indent the line.

Did you follow the troubleshooting guide? Y

Expected result

The line should be indented with the tab inserted before the “>” symbol, allowing the collapsing item to work correctly.

Actual result

The line is indented with the tab inserted after the “>” symbol, causing the collapsing item to malfunction.


	Obsidian version: v1.3.5
	Installer version: v1.3.5
	Operating system: Windows 10 Pro 10.0.22621
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

This issue is confusing and inconsistent with the expected behavior of markdown editors. It seems that the quote (“>”) should be treated as part of the item and should be indented along with the item when the tab key is pressed.

Please let me know if you need any further clarification or if there are any workarounds for this issue. Thank you for your attention to this matter.

1 Like

I found this thread because I had the same issue and my workaround is to use the <Cmd-]> macOS shortcut instead of Tab.
NB: It is not listed in hotkeys options, but it works for me.