Incorrect date in life-preview on mobile

In my mobile vault I have a start-date-event property with the property type = date. If I enter 1356-01-01 in the source view then 24. Dec 1355 is shown in life preview. Playing around with different dates around 1356, I found that there is a constant difference of 8 days between source view and life preview. However, the dates around 2020 are always correct. Amazing. Thanks for your help.

SYSTEM INFO:
Operating system: ios 17.2 (Apple iPhone)
Obsidian version: 1.4.16 (114)
API version: v1.4.16
Login status: logged in
Catalyst license: vip
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: on
RECOMMENDATIONS:
none

As I can repro :sweat_smile: , I’ve made a little bit of research and from what I understand, it’s a Julian calendar vs. Gregorian calendar thing :blush:

The Gregorian Calendar only went into effect in 1582 :blush: … and the Julian Calendar was used before.

I’ve made a Google search with this: date 1st january 1356 and Google replied to me:

Obsidian seems to do the same: It displays in Properties, the Julian calendar date 1356-01-01 “converted” into the equivalent Gregorian calendar date :blush: (24 Dec 1355).

This could probably potentially be different if in your iPhone, in the GeneralLanguage & Region setting, you select a different calendar to use (something other than Gregorian)

This is all just a hunch though :innocent: .

1 Like

Thank you, that makes sense. The settings on my iPhone allow me to choose between Gregorian, Japanese and Buddhist calendars. My settings are always set to Gregorian. I have now tried the Japanese calendar and the Buddhist calendar as well. The time shift remains stable no matter which calendar I choose.

I really had no idea if this was going to work or not :innocent:

I think I’ve made a mistake in my previous reply :sweat_smile: and I had to dig a little bit deeper than what I’ve previously did to discover that, apparently, what Properties displays/renders in Live Preview, is the equivalent Julian Calendar date corresponding to the Gregorian date entered in YAML (in Source) :innocent:.
Not the other way around as I’ve previously stated :face_with_spiral_eyes:

At least, after testing various online converter, this is the results I got :innocent: :

  • 1356-01-01 in YAML/Source is the date relying on the Gregorian Calendar

while

  • 24 Dec 1355 is its equivalent in the Julian Calendar

This is quite a confusing bug/inconsistency between desktop and mobile tbh :sweat_smile:

What got me to understand my mistake was to look for the month of October of the year 1582 (when the switch between Julian and Gregorian happened) only to discover that one can’t select a date (through the Obsidian calendar) between the 4th of October and the 15th of October in that year … and that if you select a date through the Obsidian calendar on mobile passed the 15th of October 1582, YAML and Live Preview are “in sync” again …

This doesn’t make much sense :face_with_spiral_eyes: … (especially since this distinction between the Julian calendar and the Gregorian one isn’t present on desktop)

I am very glad that you were able to replicate this issue; and thank you for your in-depth analysis. Is this a problem with Obsidian mobile or with iOS? What do you think?

I honestly have no idea :no_mouth:

I don’t have other calendars than the ones you can access at the OS level (Gregorian, Japanese and Buddhist) and it only appears in Live Preview on Obsidian Mobile :thinking: (AFAIK) …
I also don’t know what other settings I could tweak on my device to work around this…

I would be inclined to lean on an Obsidian mobile bug because YAML/Properties are managed to some extended by Obsidian…

I mean, a date you manually type in YAML in Source is actively parsed/rendered by Obsidian in Properties in Live Preview and vice-versa (a date selected in the calendar of Obsidian in Properties is then written in YAML by Obsidian)…

On the other hand, I guess I could qualify this Julian/Gregorian thing as a edge case too (as I guess not that many users would use such “old” dates in a date type of key) which should still be look at, at least for clarification :blush:

This may be a “bug” of safari’s date picker.

Does this happen on mac desktop?

That would make sense (I always forget everything Mobile goes through Safari in a way or another)…

I couldn’t reproduce on Mac (+ Obsidian 1.5+) where the date 1356-01-01 manually written in YAML in Source gets parsed in Properties as 1356-01-01 (as expected, following the ISO format I chose at the OS level, on my Mac).

Same goes if I type 1356-01-01 in a date type of key in Properties (in LP) or if I select it in the pop-up calendar in Properties: the date written in YAML (in source) matches the date I typed/selected.

In summary :innocent: , I only saw this strange Julian/Gregorian Calendar thing on my iPad (iPadOS 17.2) + Obsidian Mobile 1.4.16 (114).


Add-on: While replying here, I still tried to look for another mobile app where I could try to reproduce this issue/inconsistency and decided to look at the date picker the native Apple Reminders app’ provides when setting up a reminder :blush:

Well, the calendar also looks a bit strange for the month of October 1582 where there’s no way to select a date between the 4th and the 15th of October (same as in Obsidian Mobile, in the pop-up calendar accessible in Properties).

Selecting a date before the 15th of October 1582 doesn’t return its equivalent in the Julian Calendar as it does in Properties in Obsidian Mobile though :blush:

Here’s a screenshot of the date picker in the Reminders app :blush:

But that could confirm there’s something not quite right with the date picker on Apple’s side :blush:

…And the native Apple Calendar app’ crashes when trying to display the month of October 1582 in the “month view” :sweat_smile: . (I’ve tried quite a few times)

I can zoom in (at the month level) in any other months for the year 1582 but as soon as I get to October, the app crashes :upside_down_face:

I can only guess now that Apple didn’t manage the historical switch from the Julian Calendar to the Gregorian one as they should have :woman_shrugging:
At least, there seems to be something not quite right on iPad/iPhone…