Incorrect behaviour in vim mode when pressing "tab"

Steps to reproduce

  1. Put cursor on the last line that is a checkbox.
  2. Press “esc” more than once
  3. Press “o” to open a new line
  4. Press “tab” to indent

Expected result

the line is indented

Actual result

focus is switched to the first checkbox in the file


  • Operating system: MacOS
  • Debug info:
	Obsidian version: v0.16.2
	Installer version: v0.15.9
	Operating system: Darwin Kernel Version 16.7.0: Sun Jun  2 20:26:31 PDT 2019; root:xnu-3789.73.50~1/RELEASE_X86_64 16.7.0
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information


  1. Does it happen in the sandbox vault?
  2. Does it happen in source mode?
  3. Does it happen here ?
  4. Does it happen here ?
  1. Yes: new vault, community plugins are disabled
  2. yes: but behaviour is different, screenshot below
  3. no
  4. no: “tab” key doesn’t work on this site.


1 Like

This is a broader issue not related to vim and is due to this

let me know if it’s fixed in 0.16.3

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.