Include the full path in the source (not the target!) of linked mentions

Use case or problem

In the backlinks pane, the source should include the full path of the document, not just the document name. I use meaningful folder names, and often have documents with the same name in multiple folders. Or, rather, that’s how I like to work–but I can’t do that in Obsidian today without making the backlinks pane useless.

Note that I already know how to include the full path in backlinks—Preferences → Files & Links → New Link Format → Absolute Path in Vault. That’s not what I’m talking about here.

Screenshot included for helpfulness, with the relevant bits circled in red. The two documents named “_index” in this screenshot are different documents contained in different folders. One folder is named “Star Trek,” the other “Star Wars”–but of course you can’t see that in this screenshot.

Untitled 2

Proposed solution

See above.

Current workaround (optional)

I don’t use duplicate names for documents in different folders. This results in longer document names, redundancy, and possible errors due to typos and other causes.

1 Like