In one document, links work, and after some point they don't anymore

What I’m trying to do


In the same doc, all links below it are not showing up either. It has connections to for example “Normalization” too, but as you can see they don’t work.
(Those documents exist and have stuff written in them)

Things I have tried

I’ve never had this problem, and I just noticed it being the case. I don’t know how to reproduce it as it does work in most cases. If I make a link from “Normalization” to this doc a link appears. If I add a link next to the top link, that one works too, but now when I add it to the bottom one.

If anybody knows why or could help me fix this, that would be great.
Greetings, Nino

Look just above where everything breaks. You may have something that looks like an HTML tag that’s not closed properly. Everything after that will break. e.g.

Yeah, but that is not happening. I don’t use HTML in anyway, and the equations are all like they normally are, and well-closed. There are even two equations above the one that works.
For reference here is the code:

Because of this the [[Time-independent Schrödinger equation]] outside becomes:
\psi = 0
and inside:
- \frac{\hbar^2}{2m} \frac{d^2 \psi}{dx^2} = E \psi
\frac{d^2 \psi}{dx^2} = -k^2 \psi
k \equiv \frac{\sqrt{2mE}}{\hbar}
This is a [[Simple harmonic oscillator]] equation

I just tested it in a new document. The above text works completely fine in a new document, meaning all the links appear and nothing breaks.

It happened again:


Deleting the equation block fixed it. When I put it back, it stayed that way, meaning it is solved. Still not sure how it happened. Even if I add new links they work. It’s like the equation block froze everything, and deleting and pasting it in again, unfroze it.

This didn’t, however, work for the “Infinite square well” note. It did for a sec, but only one of the links worked, and when I put the equation block back, it broke again.