In MacOS with french keyboard layout, [⌘ command] + [` backtick] does not switch between obsidian windows

Steps to reproduce


You need a mac with keyboard layout set to French:
(note that for debugging purposes, you can easily switch between two keyboard layouts with the dedicated menu bar icon).

Also, you must have the “Move focus to next window” shortcut enabled in keyboard settings:


  1. Open two obsidian windows (e.g. two vaults).
  2. Type ⌘ command + `. To locate these on a french keyboard, see the below image. ` is located on the bottom left side of the ⏎ Enter key:

Did you follow the troubleshooting guide?


Expected result

The next window should be focused.

Actual result

` character is printed.


	Obsidian version: v1.5.3
	Installer version: v1.5.3
	Operating system: Darwin Kernel Version 23.3.0: Wed Dec 20 21:31:00 PST 2023; root:xnu-10002.81.5~7/RELEASE_ARM64_T6020 23.3.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

The ⌘ command + ⇧ shift + ` behaves normally (focus previous window in same app).

We do not officially support macos-level custom hotkey. That being, said? Does it only happen with fresh layout? I wonder if this is a dead key issue.