Impossible to open quick switcher on Android when something in selected (by the virtual keyboard)

Steps to reproduce

  1. Launch Obsidian for Android on a handset device (other form factors may be affected)

  2. Observe the command palette may be opened by using the hamburger button in the bottom-right.

  3. Observe the command palette may also be opened by swiping down from the top.

  4. Select a word of text.

  5. Observe the hamburger button is now undisplayed. Should be ok, I can just swipe down… except I can’t.

With a word selected, the hamburger button disappears and swipe-down has no effect – this it is not possible to open the command palette in this scenario, even though many commands operate directly on selected text.

Expected result

Should have some way of opening command palette that works whether or not text is selected.

Actual result

With text selected, the “Normal ways” of opening palette were unavailable or non-functioning.


Operating system: android [redacted]
Obsidian version: 1.4.3 (95)
API version: v1.1.16
Login status: logged in
Catalyst license: vip
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.1.11
Snippets enabled: 5
Restricted mode: off
Plugins installed: 39
Plugins enabled: 31
1: Dataview v0.5.55
2: Obsidian42 - BRAT v0.6.36
3: Plaintext v0.2.0
4: Settings Search v1.3.7
5: Tag Navigator v0.5.0
6: Tag Wrangler v0.5.7
7: Tasks v1.25.0
8: Templater v1.16.0
9: Sort & Permute lines v0.7.0
10: Text Format v2.2.1
11: Dynamic Highlights v0.3.1
12: Link Chopper v0.0.1
13: Editor Syntax Highlight v0.1.3
14: Minimal Theme Settings v6.3.1
15: Reveal Active File Button v2.0.3
16: Auto Link Title v1.4.1
17: Contextual Typography v2.2.4
18: Reset Font Size v1.0.2
19: Google Calendar v1.8.17
20: Copy Block Link v1.0.4
21: Full Calendar v0.10.5
22: Taskbone v1.2.3
23: Excel to Markdown Table v0.4.0
24: File Info Panel v1.3
25: Find orphaned files and broken links v1.9.0
26: Link Archive v0.2.0
27: Natural Language Dates v0.6.1
28: Home tab v1.1.2
29: Short Internal Links to Headings v1.0.2
30: Wordy v1.0.0
31: Dictionary v2.22.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Ok, I see what you mean.

This only happens when something is selected and handled by the virtual keyboard.

I wonder if the only solution for this is adding a command palette button to the input bar.

This also happens on iOS. I can confirm that you can work around it by adding a command palette button to the toolbar as WhiteNoise suggests.

1 Like

this is by default and won’t be changed. You can add “open command palette” to the mobile bar.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.