Impossible to open folder and use app on Android

Steps to reproduce

Install and run the app on an old (5.1) Android phone.
App open normally, try to create a new repository, but cannot because I need to select a folder, but when I try to select a folder, the list is completely empty.

Expected result

The folder selection shoudn’t be empty. When I tried to trobleshoot the issue, I tried installing the app using another app store (uptodown) and during the installation of the new store, the same selection view used by obsidian apeared but this time there was folders inside.
The problem is therefore probably not that selection view in particular.

Actual result

When using the obsidian app, the folder selection is completely empty.


The problem probably come from the permissions but I cannot modify the ones releted to storage space on my phone.

When reinstalling the app one more time, I found out that the storage permission is actually only for sd cards, but I don’t have an sd card!!!

So what are the solutions? Beside me bying an sd card and hoping it is the only problem.
Also, why is the permission restricted only to sd card? Security? A compatibility issue with my version of Android?

In any case, thanks for your answer.