Impossible to download installation files for any platform

Hi everyone,
I am moving from windows to linux, and want to install obsidian.
However, when trying to download any installation file the download is incredibly slow and always ends up failing.
Also tried through the console through flatpak, but when running it it gives an error.
I believe the download issue is on obsidian side, since I have no issue with other downloads.
Looking forward to a solution so anyone can restart, or start, using obsidian.
Because at moment I believe that is impossible.
Thank you for your help.

I believe it’s an issue with your network connection. Are you behind a firewall?

No firewall. I have a debian fresh install. I have no problems with other downloads.

The files are hosted on github, your ISP or they must have some routing problems in your country

I confirm. Changed ISP by downloading through a mobile phone and it worked.
It must be something about Github with my ISP.
I just wonder why…

I noticed the same. My ISP is Telekom in Germany, some IP ranges from their pool have difficulties with routing to GIthub servers (and there the AWS storages).