Importer silently truncates data

Steps to reproduce

  1. Install the Importer plugin
  2. Have at least one note that consists of one long paragraph as the first line of the note.
  3. Imported notes from Apple Notes by following your official guide

Did you follow the troubleshooting guide?

Not all steps, sorry.

Expected result

My notes fully imported. If a notes first line is too long I would expect a special case in the importer where the line is also inserted into the note and not silently truncated. I consider this bug quite serious since it can cause data loss for the user.

Actual result

I had some notes that consisted of just one long paragraph (without any title heading or new lines). That full paragraph was treated as the heading of the note and used as the filename (as it should), but since the paragraph was much longer than the filename max length the rest of the paragraph was silently truncated without any error message from the importer.


Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:05 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6000 22.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 11
Plugins enabled: 8
1: Hider v1.3.1
2: Kanban v1.5.3
3: Dataview v0.5.64
4: Advanced URI v1.38.1
5: Tasks v5.1.0
6: Advanced Tables v0.19.1
7: Tag Wrangler v0.6.1
8: Importer v1.5.5

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.