Images no longer display in Edit Mode

What I’m trying to do

This capability was working before the last update. Now all I see are links (yes, the images are there). Seems like this feature has been removed…which is very sad as it is no longer usable for note taking :frowning:

  • The files are there
  • They can be seen in read mode
  • they do not display in edit mode…anymore

Things I have tried

Searched the docs. There were a lot of requests for this to work. It was working and is working in the legacy editor.

Hi @Hotpiez It is working for me in 1.4.5 both in reading and edit/live view.

Sometimes weird issues can occur if you have different Obsidian and Installer versions. I’m not sure if the current version is one of those but worth a shot. Check if both have the same version and if not try reinstalling using the installer from the obsidian website.

Check in About (Settings | About), or in debug Info (“Open Command Palette”, start typing debug until you see “Show Debug Info”, click on it) make sure that it says the Current Version and Installer Version are the same. If not try using the installer from the website.

If that doesn’t work try posting your debug info (“Open Command Palette”, start typing debug until you see “Show Debug Info”, click on it, post the info from the box).

example from my debug:

	Obsidian version: v1.4.5
	Installer version: v1.4.5
	Operating system: Windows 10 Home 10.0.19045
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark

The reason I think this may be the issue is the installer updates a 3rd party part of Obsidian called Electron which is the editor Obsidian is built on. So, since you are having issues in the editor part, I am guessing that version mismatch could be the cause. I don’t know why Obsidian is unable to update the Electron part automatically.

1 Like

Hi @JimK , thanks for getting back to me. The installer and obsidian versions were different, and I got that fixed. That brought me to the system info where the “Live Preview” had been turned off (not sure how). That fixt the issue and I’m back in business. Thanks for the help!

1 Like

Hey @Hotpiez, no problem glad to hear you are back to the way you want it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.