Icons keep disappearing after sync and restart

I have sync and running between two computers I have obsidian installed. Macbook and PC windows 10.
My issue is that i don’t get the icons to stay between devices after syncs, as soon as I add icon on one device, and after adding and check that obsidian sync, and i restarts (app) on both, it stays on the first i added the icons on, but not synced to the other device. Let say from PC to Macbook.

Tried starting from scratch on both devices, added icons on one device and then the sync worked.

But after a while when I “usually” add new icons to obsidian via my PC, and then sync on both devices, and for some reason need to add a new icon when i´m only on my Macbook, then that icon is there after sync, but the one i added on my PC is gone after i restart the app.

Also tried to reinstall icon pack on both, but that does not help.

Both icon Pack folder have the same path, meaning:
.obsidian/icons

As extra note, i have all syncs turned on for both selective sync and vault configuration sync

I also have exact same setting for Icon Folder settings on both devices

As example:

I have on both devices same setting, no icons at all on same category, as down below under Machine Learning

I add icons on 3 folders/text, marked as yellow in the picture, and then waiting for sync on both devices, close down obsidian app on my pc (i need to close the computer when i go to sleep :slight_smile: ) and when i restart is not synced to my app in my macbook and still there on my obsidian on my PC.

So, i add 3 icons before syncing, after syncing it left on my PC where i added them

But empty on my Macbook. both checked that sync is done

And after i have waited for sync and restarted the app, nothing in my Macbook (down below), still on my PC:

That’s the first problem, the second is that, if I now have to work on my macbook and then add an icon, as highlighted in turquoise, and sync (picture above), then that icon remains in my macbook obsidian app still, but in my PC and obsidian nothing, and that is not only that it is not synced, also the three i added icons (from the first picture) plus all the other icons under machine learning are gone?!?

I need to understand one thing, maybe i have missed that completely, but can´t i add icons on one device, sync and even if the sync not working, add a new icon on the other device?

Now is a mess for me, but then again, maybe i´m doing something wrong?

NOTE:

I have now tried as a last attempt before posting this entire long post:

  1. Cleaned out all the icons in my mac book pro
  2. Removed icon plugin
  3. Disconnect from my “sync” Remote Vault
  4. Had all icons set up and controlled from my desktop PC only
  5. Connected in my mac book pro “sync” Remote Vault again
  6. Installed icon plugin
  7. Installed all icon packages
  8. Put the same path in my folder as on my desktop
  9. Restart obsidian

Nothing happens, not an icon appears in my Mac, but everything remains on my desktop PC

1 Like

(Edit: I see this is a community plugin. Moving to Help. Please follow the template for future Bug Reports.)

If it’s a community plugin, you should raise an issue on their Github page, and this thread should be moved to Help.

One other thing to double check is to make sure that you are not storing your vault in a folder on Mac or Windows that is syncing via iCloud or OneDrive. Some default folders are configured to sync with those tools. If you are, you might be having sync conflicts between those and Obsidian Sync.

If this is the Obsidian icon folder plugin, there’s a section in their readme about Sync:

There have been some syncing issues regarding the icon packs. You can change the icon pack path to .obsidian/icons to resolve the issue. Go to settings, select the plugin, and change its path to the earlier described path.

1 Like

Hi @ariehen

As you can see in my text, i did actually change to that path both on my PC and MAC (but still not working :frowning: )

I have went through the readme several times and completed step by step.

Left the same above text in github, but no response for 5 days now!!

The spooky thing is that sometimes the icons appear and then you think it worked, only to be gone again the next moment.

I don’t use the plugin, but my understanding is that you change the path so the icons purposefully aren’t synced, but I could be wrong.

1 Like

That’s a short amount of time for a) summer, b) a weekend, c) a free and open source volunteer plugin, d) a short time, period.

Please be patient. (Or you could edit the code and make a pull request.)

Hi @rigmarole

Thanks, first post so absolutely new here.

I think about this in the future.

Regarding my sync is not via Icloud or Onedrive. That was the trick.

It seems that I overlooked the small detail that there were instructions that the best way i to move from iCloud alt One Drive. I unfortunately had via iCloud on mac but correct on PC.

So after a bit of fiddling and fixing I got it. Thanks for the help.

Same issue here. Tried the new path, no joy. My vault is not in another cloud folder. Was working a month ago, but decided to add some more icons to my pack and then sync freaked out. The logs would show my desktop uploading, and then I’d open my Android and the logs would show my phone deleting them. Something’s not right. I emailed support, fingers crossed they can help.

For now, I just used Syncthing to get my icons to my phone. Also, I downloaded all 7 icon packs, picked the ones I wanted, and copied them to my own folder so now my custom icon pack is only 14 SVG files. I then deleted all the other ones

I wonder if they’re throttling my account since they see all these SVGs moving around

1 Like

Same issue here. The moment I close and restart all icons are lost. I am using Obsidan sync, other than that the vault is Not in a cloud folder. Theme ATM is Minimal in case that is relevant.

Did you try the fix that ariehen mentioned above? Icons keep disappearing after sync and restart - #3 by ariehen

It’s no longer listed in the README, but the fix might still work, or it might be no longer relevant. No idea.


You can also search the plugin’s issues for “sync”. Issues · FlorianWoelki/obsidian-iconize · GitHub and you will see there is some discussion around this.

1 Like

Thanks. That is now the default path when the plugin is installed so that is what I used from the get-go. I also paused sync in case it was related to that and the issue persists. I notice that when I enable the plugin it never shows as enabled until I quit Obsidian and restart it, which I do not believe is normal plugin behavior. What happens is when I relaunch the next time the plugin is still active, but the icons pack is completely gone. I am going to do some more testing and see what happens if i located the icon pack completely outside of Obsidian.

1 Like