iCloud sync from iPhone works (with exceptions) only one way

Platform

[x] iOS
[ ] Android

Obsidian Mobile version: v1.4.1 (83)


I have a fresh obsidian setup on my mac and iPad , both works very well and sync through iCloud surprisingly fast and reliably. Today I have installed Obsidian to iPhone and everything synced fast from iPad/Mac TO iPhone. Hovewer, when I am writing new notes on the phone they do not sync to iCloud, like files are not saving to the iCloud drive. The Obsidian folder on iCloud drive both on the iPhone and the iPad do not contain those files. Hovewer files persist between loading of the app on the iPhone (even after hard quit) (so it is cached I guess or in Core Data?).
I have tried to reinstall iPhone app with same result. This is reproducable every time. This is a fresh app store install on dec 21 so i guess the latest version.
But! Accidentally I have found that if you Share the file through share sheet on the iPhone file immediately syncs (and shows in Files), probably triggering save code, not sure. So I have a workaround but it is clearly a bug (not sure if this obsidian or iCloud but feels like obsidian?)
Also if I am trying to edit note on the iPhone that was already in iCloud it do not update on the iPad until I go to Files app on the iPhone and do the quicklook of file, then it syncs immideately , but if I edit note on the iPad it syncs almost scary fast (like almost a real time considering this is through internet;) so probably not a connection problem.

I also tried different vaults with enabled and disabled plugins with same results.

Any advice/feedback appreciated? Thanks and have a wonderful day everyone.

Actually the fact that it is synced when quicklooked probably means that this is iCloud/iOS bug however in other cases it just do not show the files (but maybe this is iCloud bug as well).

Can anyone confirm they have working setup like this and iPhone version syncs well to iCloud?

I have a similar issue. If I write something on my iPhone, it syncs, but it won’t sync if I write something on my Mac.

Did you find a solution?

Maybe you have iOS Background Sync turned off, or Low Data Mode turned on? Or maybe Low Power Mode is on but probably not since it turns off when you charge over 80%.

(I removed “[Bug]” from the title because it’s probably not an Obsidian bug.)

1 Like

I reinstalled the app one more time and it fixed the issue now sync without problem.

@CawlinTeffid nope I am pretty sure I have not disabled anything and tried it in multiple configurations. Also even if all this is turned on the app was still in foreground and nothing was happening. And it fixed itself by reinstalling with same configuration as before so not sure if this is a system thing but of course it can be. Thank you very much!

1 Like