I tried to link imgur image mark down but it doesn't show up on Obsidian

Things I have tried

I have tried to uninstall the app, removed all plugins, open a new vault but nothing work until now. I can’t embedded images only from amz and imgur image host which is very frustrating

What I’m trying to do

Can you share how exactly you wrote the image embed?

here are two examples that happen to me, both of the images work fine in notion

Perhaps notion constraint its image in *.notion.so, so you may not use notion to host images. And for imgur, perhaps ![](https://i.imgur.com/w2TN3Rs_d.webp) is a better way?

Thanks for your help ! Actually I just tried and it’s still not working

I guess maybe another image host since Im working with many images and can’t just insert png to obsidian, it will look too messy :frowning:

What you’re linking for imgur is not the direct image link but the webpage link containing the image. That’s why it doesn’t work. I’ve never had any problems with embedding images from imgur. Do not copy the link from the browser address bar. Instead, right click (or long press on mobile) on the image and select “copy image link”

did the right click copy image link, still not working here :frowning:

It works for me though?

On source mode:


On reading mode/live preview:

Remember, you have to be connected to the internet for the images to show.

1 Like

Finally it works! thank you so much

1 Like

interesting, it seems the text inside the square brackets have to be “image” or else it won’t work.

Source: Embed files\ - Obsidian Help

edit: no wait, it should work with any text. i don’t know why yours didn’t work earlier…

I dont understand either but yes should we called it a bug but only me having it ?

Well, it not work because you wrap image link with “image link”. Remove “`” and it will work.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.