I think I made a mistake - reindexing vault

I’ve been noticing this problem many times in the four years I’ve been using Obsidian. And most of the time it’s an annoyance, but tolerable. But yesterday, with the release of Insider Build 1.6.5 I decided to do a complete reindex of my vault in the hopes that that would knock some sense into it, and I’d stop being forced to wait through a reindex of hundreds of files every time I opened it on my Mac. That was a mistake. :slight_smile: Now I am waiting through the reindex of thousands of files when I opened Obsidian this morning - just like when I forced the reindex yesterday.

My vault has 20,106 files as of right now. And it grows by 10-100 every day.

What I’m trying to do

I am trying to get the reindexing to “stick.” According to the message “this should only happen once.” and it happens every time I open Obsidian ususally indexing the same approximate total number of files. In other words, I open Obsidian on my Mac and it gives me the standard

“Obsidian is indexing your vault… This should only happen once. Some functionality may not be available until this is complete. (0/483)”

The 0 number then increments through getting to usually 10-50 from the final number and the message disappears. I assume that it’s indexed.

I turn off Obsidian (after checking that sync is complete). Turn it on again later or the next day and the message is back, usually with the exact same (0/483) number.

I use Dataview heavily in my vault, so I expect it to need to index a fair amount. But on my Mac it seems like the indexing isn’t actually written to Obsidian’s files. I have no idea how that actually works, and 90% of the time I’m just glad that Obsidian does work as well as it does.

But the line “This should only happen once.” Is irritating. Because for me, it happens every time I open Obsidian. Which is significantly more than ONCE. I know this is stupid, but even if that line were just changed to refer to the interval e.g. This should only happen once [per day/per session/when you reopen Obsidian/etc.] I wouldn’t find it so irritating. But this is a me problem. :slight_smile:

Things I have tried

I have tried:

  • restarting Obsidian
  • rebooting the computer
  • updating my OS and the Obsidian installer
  • doing absolutely nothing until the entire index is “finished” (today it got to 19268 / 19271 when the window disappeared - closer than usual) - I didn’t touch Obsidian or open any other apps on my Mac until the indexing was done. I just kept jiggling my mouse so that it wouldn’t go to sleep. With 19K files, that’s pretty darn tedious. (And took like 10+ minutes).
  • searching for extremely large individual files - The largest .md file I found was 98KB, other than that the largest files are image files. I removed that file from my vault.
  • it doesn’t do the repetitive indexing on my mobile devices (iPad and phone). On those devices it just indexes every once in a while, usually if I’ve made a large number of changes on my Mac
  • meditation
  • whining to my friends and family

You don’t need to keep the notification active. The indexing continues in the background. That’s just a notification.

Because it hasn’t finished.

You either have just to wait until you vault is indexed or there is a problem in some of your files and the indexing process is stuck on those.

Do you get errors in console cmd/ctrl-opt-i?

Because it hasn’t finished.

I think you’re misunderstanding me. Wait until it finishes. EVERY SINGLE TIME. I am waiting right now for it to run through its list of 440-odd files to index. I’m watching it go through the numbers. Once it’s done I’ll go into Obsidian and begin working.

THEN

I shut down Obsidian. Restart it. And get the SAME EXACT NUMBER of files it needs to index.

What is it doing with the numbers incrementing and then disappearing if it’s not finished as you say? As I mentioned in my first post, I usually wait for it to finish before I try anything. I have waited 10 minutes and longer. And the repetitive reindexing issue doesn’t happen on any of my other devices.

Do you get errors in console cmd/ctrl-opt-i?

No. It’s surprisingly clean most of the time.

I usually have the console open to watch it. I disable and remove plugins if they get too many errors without being fixed. I have gone in and communicated with the developers on their github pages to find out what I’m doing wrong or if it’s a bug I’m seeing.

First, let’s rule out plugins.

Enable restricted mode and restart obsidian.
Let it finish indexing and see if at the next restart you get the same number of notes left.